You can skip this in seconds

Click here to continue

Aml Maple 2.62

What's Required in Version 2.62 of Aml Maple

Windows 95/98/ME/NT/2000/XP/Vista/Win7; 16 MB RAM; 1.5 MB HDD

What's New in Version 2.62 of Aml Maple

added support of Internet Explorer 8;
updated Russian help file;
updated Localization example file (LocalizationExample.lng);
some bug fixes;

Look for Similar Items by Category

System Utilities > OS Enhancements
This product is also listed in: System Tools, Office Add-ins

Feedback

Popular Downloads